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Pendahuluan

0.1 Mengenal Internet of Things
Internet of Things merupakan sebuah teknologi yang di mana mengizinkan setiap
perangkat-perangkat yang memiliki kekuatan komputasi untuk berkomunikasi satu den-
gan yang lainnya tanpa campur tangan manusia untuk menyelesaikan suatu tugas atau
fungsi.
Teknologi ini dapat diimplementasikan ke berbagai macam hal tergantung dari tugas
atau fungsi yang ingin dicapai. Sebagai contoh untuk mendesain sebuat rumah pintar
yang dapat mendeteksi lingkungan sekitar dan melakukan otomatisasi berdasarkan data
tersebut.

Gambar 1: Internet of Things

0.2 Perangkat Board IoT
Untuk membangun sebuah perangkat berbasis IoT, komponen dasar seperti Board san-
gatlah vital untuk dipunyai. Terdapat berbagai macam board yang dapat dibeli secara
luring maupun daring, dengan variasi harga yang juga berbeda mulai dari paling mu-
rah hingga mewah. Semakin kompleks masalah yang dapat diselesaikan oleh satu board,
makin mahal harga board tersebut. Contoh : NVidia Jetson untuk Image Processing
berbasis IoT.
Berikut ini adalah daftar Board yang dapat dibeli dengan harga terjangkau:

1. Arduino
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Gambar 2: Board Arduino

2. NodeMCU

Gambar 3: Board NodeMCU

3. Raspberry Pi Pico

Gambar 4: Board Pico

4. Raspberry Pi B / 2B / 3B / 4B
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Gambar 5: Board Pi 4B

5. NVidia Jetson

Gambar 6: Board NVidia Jetson

6. Orange Pi

Gambar 7: Board Orange Pi

7. Banana Pi
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Gambar 8: Board Banana Pi

Perangkat IoT dapat berkomunikasi dengan berbagai cara seperti Bluetooth, Wireless
Network, maupun jaringan kabel. Tergantung dari jenis Board yang digunakan, Board
dengan SoC seperti Raspberry Pi biasanya dilengkapi dengan Port RJ45. Sedangkan
Board mikrokontroler sederhana dilengkapi dengan nirkabel.
Selain perangkat komunikasi IoT, protokol komunikasi perangkat IoT juga mempengaruhi
bagaimana proses pengiriman dan penerimaan data dari perangkat tersebut. Terdapat
banyak sekali protokol maupun platform yang digunakan untuk berkomunikasi seperti:
Platform dan Protokol Komunikasi IoT:

1. Blynk (Platform)

2. Cayenne (Platform)

3. Telegram Bot (Platform)

4. MQTT (Protocol)

5. Web Service
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Persiapan Praktikum

Agar praktikum dapat berjalan dengan lancar, mahasiswa diwajibkan memenuhi per-
syaratan berikut baik dalam bentuk perangkat keras maupun lunak:

0.3 Perangkat Keras
Mahasiswa sebaiknya memiliki perangkat yang sama dengan modul ini, berikut ini adalah
perangkat keras yang digunakan untuk Praktikum:

• Komputer

1. Keyboard

2. Mouse

3. Display

4. Kabel Micro USB

• IoT Board

1. NodeMCU ESP 8266

2. Sensor DHT-11

0.4 Perangkat Lunak
Perangkat lunak berikut ini wajib diinstall oleh mahasiswa demi lancarnya praktikum:

• Arduino IDE (Terbaru)

– Link : https://www.arduino.cc/en/software

• USB Serial Driver (Sesuaikan Model)

– CH341 (Model ESP8266) https://github.com/nodemcu/nodemcu-devkit/blob/
master/Drivers/CH341SER_WINDOWS.zip

– CP210X (Model Amica ESP8266MOD) https://www.silabs.com/developers/
usb-to-uart-bridge-vcp-drivers?tab=downloads
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Bab 1

Praktikum 1

1.1 Konfigurasi Arduino IDE dan ESP8266
Di bagian ini mahasiswa diajarkan bagaimana menghubungkan perangkat NodeMCU ke
komputer beserta konfigurasinya hingga dapat dikenali oleh Arduino IDE. Mahasiswa di-
harapkan untuk membaca, dan memahami Persiapan Praktikum yang ada di halaman
sebelumnya.

1.2 Tutorial
1. Setelah mahasiswa menyiapkan perangkat-perangkat yang diperlukan, maka langkah

berikutnya adalah melakukan instalasi driver terlebih dahulu.

2. File driver CH341SER yang sudah diunduh, dibuka untuk diinstall. Cukup klik
Install untuk memasang driver (Windows 10 ke bawah)

3. Untuk mengecek apakah sudah sukses, gunakan Device Manager lalu tancapkan
perangkat ke port USB
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4. Langkah berikutnya adalah mengunduh Arduino IDE, usahakan untuk mendap-
atkan versi terbaru. Setelah unduh, buka aplikasi tersebut

5. NamunArduino IDE ini belummendukung perangkat yang kita gunakan. Langkah
berikutnya buka File → Preferences →. Tambahkan baris Alamat URL berikut
ke Additional board manager URLs. Klik OK untuk mengupdate otomatis.

• http://arduino.esp8266.com/stable/package_esp8266com_index.json
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6. Jika sudah, install driver ESP8266 dengan klik Boards Manager di Sidebar
Kanan atau Tools → Board: → Boards Manager

7. Di kolom Pencarian, ketik ESP8266 dan klik Install
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8. Arduino IDE sudah siap, namun belum terhubung ke perangkat. Untuk menghubungkan
antara IDE dengan ESP8266, pilih Tools → Board: → esp8266 → Generic
ESP8266 Module

9. Kemudian pastikan Port Serial yang digunakan, sama dengan yang ada di Device
Manager. Cek dengan menu Tools → Port: → Pilih COM Sesuai Device
Manager

10. Jika sudah terhubung, akan ada tanda tulisan Generic ESP8266 Module on
COMXXX di bawah kanan maupun simbol USB di atas kiri
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11. NodeMCU ESP8266 siap diujikan. Untuk menguji alat, Arduino IDE sudah
menyiapkan template dasar seperti LED Blinking. Untuk mengakses kode ini
buka menu File → Examples → ESP8266 → Blink

12. Arduino IDE akan membuka Window Baru. Tutup Window sebelumnya agar
tidak terganggu.
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13. Mahasiswa WAJIB MEMAHAMI ALUR KODE. Kode dieksekusi dari atas
ke bawah. Fungsi SETUP digunakan untuk mengatur inisialisasi yang dilakukan
SATU KALI. Sedangkan Fungsi LOOP digunakan untuk proses yang diulang-
ulang oleh alat. Kode-kode di atas kedua fungsi tersebut dianggap sebagai PA-
RAMETER GLOBAL

14. Tahap berikutnya adalah verifikasi dan upload kode. Verifikasi memastikan kode
sudah benar tanpa typo, sedangkan Upload digunakan mengunggah kode ke alat.
Sekarang klik Verify untuk memastikan kode sudah benar
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15. Jika sudah klik Upload untuk mengunggah kode ke alat. Alat akan otomatis men-
jalankan fungsinya sesuai apa yang diprogramkan.
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Bab 2

Praktikum 2

2.1 ESP8266, DHT11, dan AdafruitIO
Di bagian ini mahasiswa diajarkan bagaimana menghubungkan perangkat NodeMCU ke
sensor DHT11 dan bagaimana menyimpan data secara daring di layanan AdafruitIO.
Mahasiswa diwajibkan memahami Praktikum 1 yang ada di halaman sebelumnya.

2.2 Tutorial
1. Langkah pertama yang perlu dilakukan adalah memasang sensor ke perangkat.

Perlu diketahui bahwa dalam memasang sensor harus dalam keadaan MATI/TI-
DAK TERTANCAP untuk menghindari KORSLETING

2. Perhatikan sensor DHT11, di bagian kakinya ada tanda Plus +, Minus -, dan
Out. Sambungkan sesuai dengan indikatorNodeMCU ESP8266 sebagai berikut:

• Plus + → Vin

• Minus - → G

• OUT → D4/GPIO2
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3. Setelah selesai menancapkan sensor, berikutnya adalah melakukan registrasi ke web-
site AdafruitIO dengan link : https://io.adafruit.com/. Setelah teregistrasi akan
terlihat dasbor seperti berikut:

4. Kembali ke Arduino IDE, dan install Library dengan mengakses menu samping
atau Sketch → Include Library → Manage Libraries

5. Cari Adafruit IO Arduino, klik INSTALL, lalu INSTALL ALL
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6. Cari DHT sensor Library, klik INSTALL, lalu INSTALL ALL

7. Sesudah install, berikutnya adalah membuka Template Adafruit IO. Klik menu
File → Examples → Adafruit IO Arduino → adafruit_00_publish. Tutup
Arduino IDE lain agar fokus

8. Jika sudah terbuka, kembali lagi ke website Adafruit IO. Klik Icon Kunci Kun-
ing untuk menambahkan perangkat.
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9. Adafruit IO akan membuat kunci yang akan dimasukkan ke Sketch Arduino
IDE. Lihat bagian yang ditandai dan tempelkan ke file config.h di Tab Arduino
IDE

10. Jika sudah, buatlah Feed terlebih dahulu dengan meng klik Menu Feeds. Lalu
buat 2 Feed baru dengan nama suhu dan lembab
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11. Lalu kembali ke config.h dan ubah SSID Wifi dan Passwordnya di bagian bawahnya
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12. KonfigurasiAdafruit IO sudah selesai, berikutnya adalah memasukkan kode untuk
mengambil data sensor. Kembali ke tab arduino_00_publish.ino

13. Lalu hapus kode yang ditandai

14. Ubah kode AdafruitIO_Feed *counter = io.feed("counter"); menjadi
Potongan Kode

AdafruitIO_Feed *suhu = io.feed("suhu");
AdafruitIO_Feed *lembab = io.feed("lembab");
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15. Berikutnya adalah mengkonfigurasikan kode untuk ESP8266 dan DHT11, tam-
bahkan kode berikut tepat di bawah #include "config.h"

Potongan Kode
#include <ESP8266WiFi.h>
#include <DHT.h>

16. Lalu tambahkan kode definisi untuk jenis sensor DHT11. Tambahkan kode berikut
tepat di bawah kode io.feed. Nomor DHTPIN didapatkan dari gambar Pinout
GPIO ESP8266 via Google

Potongan Kode
#define DHTPIN 2
#define DHTTYPE DHT11
DHT dht(DHTPIN, DHTTYPE);
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17. Parameter global sudah diset. Berikutnya adalah mengatur fungsi setup untuk sen-
sor dht. Tambahkan kode berikut di bagian akhir fungsi setup (BUKAN AKHIR
FILE)

Potongan Kode
// Mulai Sensor DHT11
dht.begin();

18. Lalu tambahkan kode ke fungsi loop untuk membaca suhu dan kelembaban. Letakkan
di bawa io.run()

Potongan Kode
float temperature = dht.readTemperature();
float humidity = dht.readHumidity();
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19. Setelah itu ubah kode Serial.println(count); dengan kode berikut:
Potongan Kode

Serial.print(temperature);
Serial.print(" and ");
Serial.println(humidity);

20. Bagian terakhir yang perlu diubah adalah proses unggahnya. Ganti kode counter-
>save(count); menjadi

Potongan Kode
suhu->save(temperature);
lembab->save(humidity);
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21. Terakhir, hapus kode increment count++;

22. Verifikasi kode. Jika tidak ada Error seperti digambar. Lanjutkan denganUpload.
Pastikan NodeMCU tertancap
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23. Unggah sudah sukses

24. Berikutnya adalah mengecek alat. Klik Tools → Serial Monitor

25. Jika proses koneksi lama, cek WiFi SSID apakah sudah benar atau lemot
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26. Alat terhubung dan berhasil mengirimkan data

27. Hasil di website Adafruit IO

28. Klik salah satu feed untuk melihat data
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Potongan Kode
suhu->save(temperature);
lembab->save(humidity);

29. Untuk mengunduh, cukup klik Download Data di bagian bawah grafik

26



Bab 3

Praktikum 3

3.1 ESP8266, DHT11, dan Thingspeak
Di bagian ini mahasiswa diajarkan bagaimana menghubungkan perangkat NodeMCU ke
Thingspeak. Mahasiswa diharapkan untuk membaca, dan memahami Praktikum 2 yang
ada di halaman sebelumnya.

3.2 Tutorial
1. Untuk memulai praktikum ini, mahasiswa diwajibkan untuk membuat akun di

https://thingspeak.com/ secara gratis. Klik Get started for free

2. Klik Create one!
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3. Isi informasi identitas

4. Centang untuk menggunakan email pribadi

5. Cek email anda (termasuk SPAM) untuk verifikasi email. JANGAN TUTUP
WINDOW INI!!!
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6. Pilih negara untuk website

7. Akun sudah terverifikasi
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8. Ketika sudah selesai, kembali ke WINDOW di Langkah 5. dan klik Continue

9. Klik OK untuk pindah ke Dasbor

10. Di Dashboar akan ditanya penggunaan Thingspeak. Isi sesuai pertanyaan. Jangan
lupa untuk klik OK atau Continue
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11. Jika sudah, buat KANAL BARU dengan klik New Channel

12. Beri nama KANAL, dan isi 2 Field dengan nama Suhu dan Kelembaban. Klik
Save Channel di bagian bawah

13. Kanal sudah siap dan simpan Channel ID untuk digunakan nanti.
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14. Pindah ke tab API Keys, dan kopi Write API Key untuk Arduino IDE

15. Jika Channel ID dan Write API Key sudah didapatkan. Langkah berikutnya
adalah membuka Arduino IDE

16. Install Library Thingspeak

17. Untuk membuat program pengunggah data ke Thingspeak, gunakan Example
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yang sudah disiapkan oleh Library. Klik File → Examples → ThingSpeak →
ESP8266 → Program Board Directly → Write Multiple Fields

18. Jika sudah, simpan projek sebagai Praktikum 3

19. Ketika sudah siap, cukup edit file secrets.h melalui tab. Isi sesuai konfigurasi
sebelumnya.

20. Kembali ke file Praktikum3.ino. Tambahkan Library DHT di bawah ThingS-
peak.h. Lihat gambar

Potongan Kode
#include <DHT.h>
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21. Hapus kode berikut

22. Ganti kode yang sudah dihapus tadi dengan kode berikut:
Potongan Kode

#define DHTPIN 2
#define DHTTYPE DHT11
DHT dht(DHTPIN, DHTTYPE);
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23. Lalu di dalam FUNGSI SETUP, tambahkan kode berikut setelah baris ThingS-
peak.begin():

Potongan Kode
// Mulai Sensor DHT11
dht.begin();

24. Di dalam FUNGSI LOOP Hapus kode berikut:
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25. Hasil AKHIR SEHARUSNYA:

36



26. Jika sudah tambahkan kode berikut tepat di atas ThingSpeak.setField()
Potongan Kode

float temperature = dht.readTemperature();
float humidity = dht.readHumidity();

27. Lalu ubah kode di dalam ThingSpeak.setField sesuai kode berikut:
Potongan Kode

ThingSpeak.setField(1, temperature);
ThingSpeak.setField(2, humidity);
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28. Verifikasi untuk memastikan kode sudah benar. Lalu klik Upload

29. Data terkirim dan terunggah
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30. Untuk download data, klik Export recent data di halaman yang sama. Pilih
masing-masing Field dengan format CSV
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Bab 4

Praktikum 4

4.1 ESP8266, DHT11, dan Firebase Realtime
Di bagian ini mahasiswa diajarkan bagaimana menghubungkan perangkat NodeMCU ke
Firebase Realtime. Mahasiswa diharapkan untuk membaca, dan memahami Praktikum
3 yang ada di halaman sebelumnya.

4.2 Tutorial
1. Buka browser lalu klik link berikut : https://console.firebase.google.com/.

Login dengan akun Google dan klik kembali link terssebut.

2. Buat projek baru dengan melakukan klik tanda +
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3. Isi nama projek

4. Matikan Google Analytic dan klik Create Project

5. Tunggu proses berlangsung dan klik tombol apabila sudah muncul
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6. Firebase akan menampilkan dasbor sistem

7. Klik Build dan pilih Realtime Database

8. Klik Create Database
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9. Pilih Lokasi dan Klik Next

10. Pilih Locked Mode dan klik Enable

11. Database sudah dibuat
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12. Sebelumnya ubah aturan database dengan klik Rules, dan ubah kata false menjadi
true. dan klik Publish

13. Untuk membuat kunci, klik Roda Gigi Project Overview, pilih Project Set-
tings

14. Di bagian General, scroll turun hingga menemukan Apps
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15. Di bagian Your Apps pilih Web

16. Isikan nama app, dan pilih Register app

17. Di tahap selanjutnya, sistem akan membuat API Key dan Database URL. Kopi
data ini ke Notepad
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18. Di Arduino IDE, buka Libraries dan install ESP8266 Firebase dan Firebase
Arduino Client Library

19. Buat projek baru dengan template yang sudah ada. Klik File → Examples →
Firebase Arduino Client Library for ESP8266 and ESP32→ FirebaseJson
→ Client → Firebase
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20. Hapus beberapa bagian kode berikut:

• Bagian 1

• Bagian 2
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21. Lalu kembali ke bagian atas, dan ubah kode berikut:

22. Bagian berikutnya adalah akun. Buka kembali Firebase, buka menu Build lalu
Firebase Authentication

23. Pilih Email/Password, klik semua menjadi Enable, dan Save

24. Kembali ke tab User, klik Add User, isikan Email dan Password, klik Add
User
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25. Kembali lagi ke Arduino IDE dan ubah bagian Email dan Password

26. Berikutnya adalah menambahkan kode untuk sensor DHT
Potongan Kode

#include <DHT.h>

#define DHTPIN 2
#define DHTTYPE DHT11
DHT dht(DHTPIN, DHTTYPE);
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27. Tambahkan di bagian akhir kode void setup() dengan kode berikut:
Potongan Kode

// Mulai Sensor DHT11
dht.begin();

28. Di dalam kode void loop() setelah kode if, masukkan kode berikut
Potongan Kode

float temperature = dht.readTemperature();
float humidity = dht.readHumidity();
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29. Setelah itu untuk menyusun query nya, masukkan kode berikut. GANTI baris yang
ditandai sesuai dengan kode berikut

Potongan Kode
FirebaseJson json;
json.setDoubleDigits(3);
json.add("temperature", temperature);
json.add("humidity", humidity);

Serial.printf("Set json... %s\n", Firebase.RTDB.setJSON(&fbdo,
"/livedata", &json) ? "ok" : fbdo.errorReason().c_str());

Serial.printf("Push json... %s\n", Firebase.RTDB.pushJSON(&fbdo,
"/history", &json) ? "ok" : fbdo.errorReason().c_str());

30. Verifikasi dan Upload aplikasi

51



31. Data sukses diunggah

32. Hasil
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Bab 5

Praktikum 5

5.1 NodeMCU, DHT11, dan Web App
Di bagian ini mahasiswa diajarkan bagaimana menghubungkan perangkat NodeMCU ke
Web App sehingga dapat dipantau dan unduh secara daring secara bersamaan. Maha-
siswa diharapkan untuk membaca, dan memahami Praktikum 4 yang ada di halaman
sebelumnya.

5.2 Tutorial
1. Untuk memulai praktikum ini, mahasiswa diwajibkan menyelesaikan Praktikum 4

2. Jika sudah, buka https://pythonanywhere.com/. Dan buatlah satu akun di website
tersebut.

3. Jika sudah buka halaman dasbor seperti gambar berikut:

4. Untuk memulai membuat Web apps, klik Open Web tab
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5. Di halaman berikutnya buatlah satu Web app dengan klik Add a new web app

6. Berikutnya klik Next saja karena nama web akan default ke username

7. Berikutnya adalah memilih Engine API. Klik Flask
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8. Berikutnya pilih Python 3.9

9. Ubah target direktori dari (JANGAN DIKOPI DAN TEMPEL):
Sebelum

/home/maulana9406/mysite/flask_app.py

Sesudah
/home/maulana9406/IoTWebApp/main_app.py

10. Jika sudah, website akan membawa ke Configuration Web App
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11. Buka Files di Tab Baru

12. Di bagian ini mahasiswa dapat melihat struktur direktori Web App. Buka folder
IoTWebApp di bagian kiri

13. Pastikan mahasiswa sudah membuka folder IoTWebApp. Jika sudah, buatlah satu
folder dengan nama templates. Masukkan kata templates lalu Enter

14. Jika folder sudah di buat. Berikutnya adalah membuat file dengan nama in-
dex.html di bagian kanan.
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15. Jika sudah, buka file index.html, masukkan kode berikut, dan simpan
Sesudah

<!-- templates/index.html -->
<!DOCTYPE html>
<html>

<head>
<title>Internet of Things Web App</title>

</head>
<body>

<h1>Aplikasi web untuk memantau suhu dan kelembaban</h1>

<div id="reloadData" style="border: 2px solid #000;
outline: 2px solid #f00; padding: 20px;">
<!-- Konten ini akan di perbarui -->

</div>

<script src="https://code.jquery.com/jquery-3.6.0.min.js"></script>
<script>

function reloadData() {
$("#reloadData").load("/reload");

}

function openLink() {
var urlToOpen = '/download';
window.open(urlToOpen, '_blank');

}

// Refresh the div every 5 seconds (5000 milliseconds)
setInterval(reloadData, 5000);

// Initial load
reloadData();

</script>
<div>

<button onclick="openLink()">Unduh Data</button>
</div>
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</body>
</html>

16. Kembali ke folder atas dengan klik IoTWebApp di bagian atas. Lalu buka file
main_app.py

17. Di dalam file main_app.py ini. Di bagian paling atas ada perubahan kode seperti
berikut:

Sebelum
from flask import Flask

Sesudah
from flask import Flask,render_template, send_file
from datetime import datetime
import requests
import csv
import time
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18. Lalu ubah kode untuk akses Home. Perhatikan perubahan kode berikut:
Sebelum

@app.route('/')
def hello_world():

return 'Hello from Flask!'

Sesudah
@app.route('/')
def home():

return render_template("index.html")

19. Setelah itu di baris bawah lagi, tambahkan kode untuk melakukan reloading untuk
menampilkan data dari database dan mengunduh file. GANTI <URL> dengan
Database masing-masing
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Sesudah
# APIs
@app.route('/reload')
def reload_data():

# Ambil Data
url = "<URL REALTIME DATABASE>"
url += "livedata.json"
resp = requests.get(url)
if resp.status_code == 200:

data = resp.json()
suhu = str(data['temperature'])
lembab = str(data['humidity'])

else:
suhu = "NaN"
lembab = "NaN"

resp.close()

# Set Waktu
now = datetime.now()
waktu = now.strftime("%H:%M:%S %d-%m-%Y")

# Susun HTML Data
msg_data = f"<h3>Suhu : {suhu}</h3>"
msg_data += f"<h3>Lembab : {lembab}</h3>"
msg_data += f"<h3>Waktu : {waktu}</h3>"
return msg_data

20. Terakhir adalah membuat kode unduh. Tambahkan kode berikut tepat di bawah
kode reload. GANTI <LINK URL> dan <USERNAME> sesuai masing-masing
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Sesudah
# APIs
@app.route('/download')
def download_csv():

# Ambil Data
url = "<URL REALTIME DATABASE>"
url += "history.json"
resp = requests.get(url)
if resp.status_code == 200:

data = resp.json()

# Bangun file CSV
rows = []
for key,_ in data.items():

row = []
row_data = data[key]
# Isi baris CSV
row.append(row_data['temperature'])
row.append(row_data['humidity'])
rows.append(row)

else:
rows = [[]]

file_path = '/home/<USERNAME>/IoTWebApp/Data.csv'
custom_filename = 'Data Pemantauan DHT11.csv'

# Buat file CSV -> Data.csv
header = ['Temperature',"Humidity"]
with open(file_path,"w") as f:

writer = csv.writer(f)
writer.writerow(header)
for input_row in rows:

writer.writerow(input_row)

# Kirim File
return send_file(file_path, as_attachment=True,

download_name=custom_filename)
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21. Langkah terakhir, melakukan Reloading Web App dengan kembali ke Tab Web
dengan tampilan di Langkah 11. Tunggu hingga selesai

22. Klik nama website untuk membuak Web

23. Lihat dan coba Web App
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24. Klik Unduh Data untuk mengambil data CSV
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Bab 6

Praktikum 6

6.1 ESP8266, DHT11, dan Telegram Bot
Di bagian ini mahasiswa diajarkan bagaimana menghubungkan perangkat NodeMCU ke
Telegram Bot. Mahasiswa diharapkan untuk membaca, dan memahami Praktikum 5
yang ada di halaman sebelumnya.

6.2 Tutorial
1. Tahap pertama yang dilakukan adalah membuat Telegram Bot. Pastikan untuk

memiliki Akun Telegram untuk bisa memulai langkah ini

2. Cari Bog Manager dengan @BotFather

3. Gunakan perintah /newbot untuk membuat Telegram Bot baru
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4. Lalu masukkan nama dari Telegram Bot

5. Lalu masukkan username untuk mempermudah pencarianTelegram Bot. Pastikan
memiliki akhiran _bot
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6. Telegram Bot sudah jadi dan Token API akan ditampilkan. Simpan baik-baik
kode tersebut

7. Berikutnya adalah membuka kembaliPraktikum 4 dengan menggunakanArduino
IDE. Lakukan Save As untuk menyimpan sebagai Praktikum 6

8. Install Library dengan nama FastBot
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9. Berikutnya adalah mendapatkan Chat ID melalui Bot https://t.me/chatIDrobot

10. Setelah itu tambahkan kode berikut tepat setelahRTDBHelper.h. Lalu masukkan
TOKEN BOT dan Chat ID di kode berikut

Sesudah
#include <FastBot.h>
#define BOT_TOKEN "<TOKEN BOT>"
#define CHAT_ID "<Chat ID>"
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11. Setelah itu masukkan kode untuk inisialisasi Bot dengan menambahkan kode berikut
di atas void setup()

Sesudah
FastBot bot(BOT_TOKEN);

12. Setelah itu, cukup tambahkan kode berikut tepat di akhir fungsi void loop()
Sesudah

bot.setChatID(CHAT_ID);
bot.setTextMode(FB_MARKDOWN);

char buffer[40];
sprintf(buffer, "Suhu : %f, dan Kelembaban : %f", temperature, humidity);
Serial.println(buffer);

bot.sendMessage(buffer);
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13. Verifikasi dan Upload kode ke Perangkat
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Bab 7

Praktikum 7

7.1 Observasi dengan Internet of Things
Di bagian ini mahasiswa diajarkan bagaimana melakukan pengambilan data lingkungan
dengan menggunakan Internet of Things. Mahasiswa diharapkan untuk membaca, dan
memahami Praktikum 6 yang ada di halaman sebelumnya.

7.2 Tutorial
1. Mahasiswa perlu menyiapkan perlengkapan berupa:

• Perangkat dari Praktikum 6 yang sudah dilengkapi dengan Firebase dan Tele-
gram Bot

• Charger HP dan Kabel MicroUSB

• Akses Internet

2. Pastikan Akses Poin sudah sesuai dengan kode perangkat Internet of Things

3. Jika semua sudah berjalan dengan baik, Telegram Bot akan mengirimkan data dan
Firebase Realtime DB akan merekam semua data.

4. Setelah satu jam, data yang terkumpul dapat diunduh melalui Web App.

5. Kirim data CSV ke Praktikum 7

6. Buat laporan sesuai dengan template yang ada di berikutnya dan kirim ke Prak-
tikum 8
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Bab 8

Praktikum 8

• Laporan hasil mengikuti format seperti berikut

1. Cover Laporan dengan nama tim lengkap

2. Halaman Daftar Isi

3. Spesifikasi Model (Jelaskan komponen-komponen yang digunakan)

4. Proses Observasi (Jelaskan proses observasi dengan alatnya)

5. Hasil Observasi #1 (Berupa Tabel Sampel Data - 15 baris data)

6. Hasil Observasi #2 (Berupa Grafik masing-masing data, Suhu dan Kelembaban
diurutkan berdasarkan waktunya)

7. Analisis Hasil Observasi (Jelaskan hasil observasi yang didapatkan)

8. Kesimpulan

• Laporan dikirimkan ke Praktikum 8

• Format File hanya PDF

71


	Pendahuluan
	Mengenal Internet of Things
	Perangkat Board IoT

	Persiapan Praktikum
	Perangkat Keras
	Perangkat Lunak

	Praktikum 1
	Konfigurasi Arduino IDE dan ESP8266
	Tutorial

	Praktikum 2
	ESP8266, DHT11, dan AdafruitIO
	Tutorial

	Praktikum 3
	ESP8266, DHT11, dan Thingspeak
	Tutorial

	Praktikum 4
	ESP8266, DHT11, dan Firebase Realtime
	Tutorial

	Praktikum 5
	NodeMCU, DHT11, dan Web App
	Tutorial

	Praktikum 6
	ESP8266, DHT11, dan Telegram Bot
	Tutorial

	Praktikum 7
	Observasi dengan Internet of Things
	Tutorial

	Praktikum 8

